www.pryy.net > wEBlogiC 使用JDK1.7后启动报错

wEBlogiC 使用JDK1.7后启动报错

weblogic9-->jdk1.5 weblogic10.XXX-->jdk1.6 weblogic12c-->jdk1.7 随便改会有兼容上的问题。

带的是1.6的JDK,不是,是根据weblogic的版本选择JDK,当然如果不支持64的系统中就不能用64位的。

估计是 JRE 目录设置不正确,Weblogic 没能在指定的目录下找到 java.exe 之类的必要文件。 JAVA_HOME 是指到能在它的目录下找到 bin\java.exe 或 bin\jvm.dll 的目录。比如你的 D:\JDK\bin 则 JAVA_HOME 应该是 D:\JDK 或 D:\JDK\jre 而不是 D:\...

weblogic 8.16 是weblogic 8的最高版本 ,最高只支持到JDK1.4.2,你用1.5当然有问题,编译规范都有较大的差别!

是不是没有这个文件:/home/beax/weblogic92/server/native/linux/x86_64/libmuxer.so,重装一下weblogic

下标越界错误,检查一下你的数组下标的设置。

在安装weblogic时会检查JDK的,都安装好了说明你的JDK当时配置是正确的,之后出错可能有以下原因: 1、安装完成之后你更改了JDK 2、你安装weblogic和配置环境变量是用的一个账户,而你现在遇到问题是用的另外一个账户

大哥,能给点报错信息么?不然咋判断什么问题呢?

weblogic11g好像还只能支持jdk1.6,不能支持jdk1.7,weblogic12c好像能支持jdk1.7

jdk版本问题,你用的jdk应该是官方的,weblogic一般用自带的jdk,可以使用jrockit的选项。 检查下启动的sh,path变量,把里头jdk相关的内容再检查检查,应该指向weblogic自带的jdk位置

网站地图

All rights reserved Powered by www.pryy.net

copyright ©right 2010-2021。
www.pryy.net内容来自网络,如有侵犯请联系客服。zhit325@qq.com